How to resolve common Xero sync errors

  • Updated

This article provides a troubleshooting guide for resolving common sync issues encountered between Re-Leased and Oracle NetSuite. If you're facing errors during the syncing process, understanding the potential causes and solutions will empower you to rectify them swiftly, ensuring a seamless integration of your financial data.

 

Sync Error Message Potential cause and how to fix
A contact with this name already exists please use a different name

Cause of the error

There can't be more than one contact in Re-Leased with the same name. This usually surfaces when there is a Vendor and Customer in Oracle NetSuite with the same name.

How to resolve

Rename the duplicate contact in Oracle NetSuite - this will usually be the Vendor contact.

Invoice/contact is using multi-currency. This feature is not currently supported by Re-Leased

Cause of the error

An invoice or contact in Oracle NetSuite is set up to use multi-currency, which is not supported by Re-Leased.

How to resolve

The invoice or contact needs to be unlinked from Re-Leased. Once unlinked, it's recommended to make the contact inactive in Oracle NetSuite and create a new contact in your local currency.

Payment has linked transaction(s) of type(s) 'Journal Entry' and is not currently supported by Re-Leased

Cause of the error

Journal Entries don't sync from Oracle NetSuite to Re-Leased as they're not currently supported.

How to resolve

The payment will need to be unlinked. Once unlinked, a payment can be added to the invoice in Re-Leased and it won't sync to Oracle NetSuite as it's already been paid there.

INSUFFICIENT_PERMISSION: Permission Violation: You need a higher permission for [record type] to access this page

Cause of the error

The Re-Leased Integration Role does not have permission to access a custom record or field referenced on the transaction.

How to resolve

In NetSuite, navigate to the custom record type or field mentioned in the error and grant the Re-Leased Integration Role at least View permission. For custom records, add the role under the Permissions subtab. For custom fields, update the Access subtab.

Still having issues?

If you've verified the above and the issue persists, please contact Re-Leased Support for assistance.

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